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Dieser Artikel soll ein kleiner Wegweiser sein, um erfolgreich einen Charakter
mit Maya zu modellieren.

Vorgehensweise:

1. Entwurf des Charakters: Zeichnen des Charakters in Front- und Sei-
tenansicht (Minimum). Wenn nötig kann auch eine Ansicht von oben oder
weitere Ansichten gezeichnet werden. Anschließend werden die Zeichnun-
gen eingescannt und als Imageplanes in die entsprechenden Ansichtsfenster
von Maya geladen.

View→Image Plane → Import Image

Dann die Bilder auswählen. Damit die Imageplanes die modellierte Geo-
metrie nicht verdecken, ist es ratsam, die Position der Imageplane nach
hinten (relativ zur orthographischen Camera) zu schieben. Beispielsweise
bei den Image Plane Attributes des side-Views:

View→Image Plane → Import Plane Attributes, Placement Extras→Center auf -100,0,0

Wenn man sich im perspektivischen View davon überzeugt hat, dass die
Bildebenen gut zusammen passen, kann man sie im perspektivischen View
wieder ausblenden:

View→Image Plane → Import Plane Attributes, Display→looking through camera

Tip: Als hilfreich hat sich dabei herausgestellt, wenn bei den Zeichnungen
der Hintergrund nicht weiß ist, sondern mittelgrau. Dies kann in einem
Bildbearbeitungsprogramm auch nach dem Scannen noch gesetzt werden.

2. Modellieren mit Polygonen:
In den Übungsstunden wurde das Modellieren mit Polygonen ausführlich
besprochen. Wichtig ist hier die Frage, wann das Polygonmodell in eine
Subdivision-Surface konvertiert wird. Hier hat sich folgende Strategie als
sinnvoll erwieden:

• Überlegt Euch aus welchen separaten Teilen ihr Euer Modell auf-
bauen wollt. Bei einem Charakter, der keine Kleidung tragen wird
es sinnvoll sein, den gesamten Körper als eine zusammenhängende
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Fläche zu modellieren. Wird der Charakter beispielsweise ein Hemd
tragen, ist es besser z.B. Hemd und Kopf als separate Flächen zu
modellieren und den Hals im Hemd verschwinden zu lassen. Dabei
ist lediglich darauf zu achten, dass auch bei den beabsichtigten Ani-
mationsposen keine Lücken (beispielsweise zwischen Hals und Hemd)
sichtbar werden können.

Tip: Bei dieser Entscheidung sollte nur die geometrische Form des
Charakters in Betracht gezogen werden, nicht auf die Materialeigen-
schaften! Es ist leicht möglich Materialeigenschaften an unterschied-
liche Teilflächen der Polygonfläche zu binden. Es ist jedoch nahezu
unmöglich während der Animation zwei separate Flächen glatt und
lückenlos zu bewegen!

• Fangt an den Kopf des Charakters als Polygonfläche zu modellie-
ren. Dabei sollte man immer im Auge behalten, dass man später die
Polygonfläche in eine glatte Subdivision-Surface konvertieren will:

– Die Polygone sollten nur grob der gezeichneten Geometrie ent-
sprechen. Hier ist etwas Vorstellungsvermögen gefragt.

– Überlegt Euch genau wo an Eurem Objekten scharfe oder halb-
scharfe Kanten auftreten und berücksichtigt dies bei der Model-
lierung indem ihr genau dort die Polygonkanten hinlegt. Wenn
man später eine Subdivision-Surface hat, kann man für jede Kan-
te genau festlegen wie scharf die Kante sein soll!

– Es kann natürlich sein, dass bestimmte Kanten nur in bestimm-
ten Animationsposen auftreten (z.B. Lachfalten). Auch dies soll-
te man vorher bei der Polygonfläche miteinbeziehen!

– Polygonkanten sollten auch dahin gelegt werden, wo später Mate-
rialkanten auftreten (z.B. beim Batman-Modell zwischen Gesicht
und Maske)

Folgende Grundregeln haben sich als sinnvoll herausgestellt. Diese
Regeln sind nicht zwingend und sollten nur als Richtlinien gesehen
werden. Es mag nicht immer möglich sein, alle Regeln vollständig zu
erfüllen:

(a) Verwendet möglichst wenige Polygone. Eure gesamte Proxy-
Geometrie sollte nicht mehr als 2000 Polygone haben!

(b) Verwendet wenn möglich Vierecke, dann wird die Subdivision-
Surface später nicht unnötig komplex.

(c) Verwendet möglichst planare Polygone, d.h. alle Vertices lie-
gen möglichst auf einer Ebene. Zu starke Verzerrungen führen
meist zu ungewollten und unschönen Resultaten.

• Speichert von Zeit zu Zeit Eure Polygonfläche ab. Es kommt
hin und wieder vor, dass Maya etwas Unerwartetes macht (gar abstürzt).
Wenn ihr abgespeichert habt, konvertiert Eure Polygonfläche
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testweise in eine Subdivision-Surface und schaut Euch an, ob das
Ergebnis Euren Erwartungen entspricht. Ladet dann aber die Poly-
gonfläche wieder und arbeitet daran weiter.

• Wenn ihr mit einem Teil zufrieden seid, löscht die Construction-
History!

Edit→Delete All by Type → History

• Auf diese Weise modelliert ihr alle Teile (Kopf, Arme, Beine) Eures
Charakters zunächst separat. Je nachdem aus welchen Teilen Eu-
re Modell besteht werdet ihr unabhängig modellierte Teile, zu einer
einzigen Fläche zusammenfügen wollen. Dies ist nicht schwierig, man
sollte nur einige Dinge beachten.
Wenn man zwei separate Flächen konstruieren will, die exakt anein-
ander passen sollen, muß man an den Anschlußkanten die Vertices
exakt überlagern. Dies ist einfach, wenn man die Vertices mit dem
Move-Tool verschiebt und dabei die Taste v gedrückt hält. Dann
schnappen die Vertices auf andere Vertices ein (Aber schaut Euch
das Ergebnis in verschiedenen Views an, denn man verliert leicht die
Orientierung!)
Vor dem Verschmelzen zweier Polygonflächen sollte man sich ver-
sichern, dass beide Teilflächen die gleiche Orientierung haben. Dies
kann man überprüfen, indem man sich die Oberflächennormalen an-
zeigen läßt mit:

Display→Polygon Components→Normals

Zeigen die Normalen der einzelnen Flächen in unterschiedliche Rich-
tungen, so kann man eine Fläche auswählen und mit folgendem Befehl
die Normalenrichtung ändern:

Edit Polygons→Normals→Reverse

Dies kann man auch für einzelne Polygone machen, falls es notwendig
sein sollte.
Wenn alles ok ist kann man zwei Polygonflächen mit dem Befehl

Polygons→Combine

zu einer einzigen zusammenfügen. Anschließend sollte man noch dop-
pelte Vertices und Kanten verschmelzen mit

Edit Polygons→Merge Vertices

und
Edit Polygons→Merge Multiple Edges

Nachdem alle Polygonflächen, die zusammengehören, miteinander kombi-
niert wurden, muß sichergestellt sein, dass es sich bei der Gesamtfläche
um eine sog. Mannigfaltigkeit handelt, sonst läßt sie sich nicht in ei-
ne Subdivision-Surface konvertieren. Die Definition einer Mannigfaltigkeit
wird in der CG-II Vorlesung erklärt. Für uns heißt das zunächst nur...
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• ...dass es keine Kante im Polygonnetz geben darf, an der mehr als
zwei Polygone anschließen.

• ...dass es keinen Punkt gibt, an dem vier Randkanten aufeinander-
stoßen.

Es gibt mehrere Möglichkeiten solche Problemfälle zu beheben. Die Behe-
bung sollte allerdings manuell erfolgen, da die automatische Cleanup Funk-
tion von Maya üblicherweise nicht die Ergebnisse liefert, die man haben
will. Die Cleanup Funktion ist allerdings sinnvoll, um sich Nichtmannigfal-
tigkeiten anzeigen zu lassen. Wählen sie (am besten im Wireframe-Modus
(Taste 4)) den Befehl

Polygons→Cleanup

mit der Option Box und wählen sie bei Operation den Eintrag Select Geo-
metry sowie das Häkchen bei Nonmanifold geometry. Problemstellen werden
dann gehighlightet. Diese Problemfälle lassen sich manuell durch Manipu-
lation einzelner Vertices mit der Funktion

Edit Polygons→Split Vertex

beheben.

Als Abschluß sollte man sich noch alle Randkanten anzeigen lassen, um
zu überprüfen, das bei der Modellierung keine Löcher entstanden sind:

Display→Polygon Components→Border Edges

Sieht man nun eine unbeabsichtigte Randkante, die sich durch Merge Mul-
tiple Edges nicht beheben läßt, so liegt meist der Fall vor, dass zwei Vertices
sehr nahe beieinander liegen, aber nicht exakt aufeinander. Dies behebt
man am besten indem man einen der Vertices selektiert, ihn mit dem
Move-Tool bei gedrückter Taste v auf den anderen einschnappen läßt
und anschließend Merge Vertices aufruft.

Wenn alles ok ist, kann die Fläche testweise in eine Subdivision Surface
konvertiert werden. Bevor wir aber endgültig mit der Subdivision Surface
weiterarbeiten, wollen wir zunächst die Texturkoordinaten generieren, da
dies für Polygonflächen sehr viel einfacher ist, als für Subdivision Surfaces.

3. Vorbereiten für die Texturierung (OPTIONAL)
Um unser Modell später mit Texturen versehen zu können, müssen wir
zunächst Texturkoordinaten generieren. Eine Textur ist ein Bitmap (d.h.
ein 2D Pixelbild), das ähnlich einer Tapete auf das Polygonmodell geklebt
werden kann. Im Rahmen unseres Praktikums werden Texture optional
behandelt, d.h. wer keine Texturen haben will, muß auch keiner verwen-
den. Texturen verbessern jedoch sehr stark den visuellen Eindruck des
Charakters.

Wenn wir Texturen verwenden wollen, müssen wir Maya zunächst mit-
teilen wie unsere 3D Polygonfläche auf die Ebene abgebildet werden soll.
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Die empfohlene Strategie ist hier, Teile (d.h. Faces) der Polygonfläche aus-
zuwählen und diese auf einfache Flächen (z.B. eine Ebene, einen Zylinder
oder eine Kugel) zu projizieren. Die Texturkoordinaten werden als werte
(u, v) angegeben, um sie von den Vertex-Koordinaten (x, y, z) zu unter-
scheiden.

• Wählt entweder Euer gesamtes Objekt aus, oder selektiert einzelne
Flächen, die auf die Textur abgebildet werden sollen.

• Öffnet zunächst den UV Texture Editor unter
Window→UV Texture Editor...

Ihr seht nun in dem Fenster, wie die ausgewählten Flächen Eu-
res Objekts auf die 2D-Textur-Ebene abgebildet werden. Dies ist
wahrscheinlich nicht, das was ihr haben wollt, da sich die Flächen
womöglich überschneiden und ihr somit keine konsistente Textur be-
kommt.

• Wählt nun - je nachdem welche Form Euer Objekt hat - einen der
folgenden Befehle aus:

Edit Polygons→Texture Editor→Planar Mapping

Edit Polygons→Texture Editor→Cylindrical Mapping

Edit Polygons→Texture Editor→Spherical Mapping

Es erscheint dann ein Manipulator, der es Euch ermöglicht die Form auf
die Eure Auswahl projiziert wird noch zu verändern. Ihr seht die Ände-
rungen direkt im UV-Texture-Editor. Mit dieser Methode versucht ihr
zunächst einzelne Teile Eurer Polygonfläche auf unterschiedliche Teile der
UV-Textur-Ebene abzubilden.

Anschließend könnt ihr Euere Texturkoordinaten im UV-Texture-Editor
noch manuell nachbearbeiten. Klickt im UV-Editor rechts mit der Maus
auf Euer Objekt und selektiert UV. Ihr könnt die (u, v)-Koordinaten selek-
tieren und mit den bekannten Manipulatoren (Translate, Rotate, Scale)
verändern.

Wenn ihr einzelne Teilflächen Eures Objekts separat projiziert habt könnt
ihr die einzeln projizierten Teile auch wieder zusammenfügen. Dies geht,
indem ihr auf die gleiche Weise Edges selektiert und die Randkanten Eu-
rer Teilfläche auswählt. Wenn ihr eine Kante auswählt highlightet Maya
automatisch auch die entsprechende Kante der anderen Teilfläche und ihr
könnt sie mit

Polygons→Move and Sew UVs

aus der Menüleiste des UV-Texture-Editors zusammenfügen lassen.

Ziel des ganzen ist es, die Oberfläche Eures Polygonobjekts so auf die
(u, v)-Ebene abzubilden, das die Polygone möglichst wenig verzerrt wer-
den. Dies ist natürlich nur bedingt möglich. Außerdem sollte man darauf
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achten, das Nahtstellen in der Textur möglichst an verdeckten Stellen des
Objekts liegen.

Um allzugroße Verzerrungen, die durch das Editieren der Texturkoordina-
ten entstanden sind wieder auszugleichen, kann die Funktion

Polygons→Relax UVs

aus dem UV-Texture-Editor (mehrfach) angewendet werden (Option-Box
beachten!).

Anmerkung: Maya kann Euch Eure Textur-Koordinaten auch vollauto-
matisch generieren mit dem Befehl

Edit Polygons→Texture Editor→Automatic Mapping

allerdings entspricht das Resultat oft nicht dem was man haben will und
die Textur enthält viele kleine unzusammenhängende Polygone.

4. Konvertierung in eine Subdivision Fläche

Wenn ihr die Texturkoordinaten generiert habt, könnt ihr Eure Polygon-
fläche in eine Subdivision-Fläche konvertieren. Wählt einfach

Modify→Convert→Polygon to Subdivision

mit der Option-Box. Setzt Maximum Base Mesh Faces auf ca. 3000 hoch,
damit ihr keine Probleme bei der Konvertierung bekommt. Wählt Stan-
dard (no history) und setzt das Häkchen Keep Original, um die
Original-Polygonfläche nicht zu löschen. Anschließend könnt ihr die Poly-
gonfläche unsichtbar machen (z.B. indem ihr im Show-Menü Eures aktiven
Views die Sichtbarkeit von Polygonen ausschaltet). Wenn Eure Subdivision-
Surface etwas grob aussieht, dann drückt einfach die Taste 3 um die Dar-
stellungsgenauigkeit hochzusetzen.

Als nächstes solltet ihr bei Eurem Subdivision Modell die Creases set-
zen. Dies funktioniert indem ihr Edges selektiert, und die entsprechenden
Kanten auswählt. Mit dem Befehl

Subdivi Surfaces→Full Crease Edge/Vertex

könnt ihr scharfe Kanten setzen. Wenn ihr nicht komplett scharfe Kanten
haben wollt, könnt ihr wiederholt den Befehl

Subdivi Surfaces→Partial Crease Edge/Vertex

bis Eure Kante den gewünschten Schärfegrad erreicht hat.

Tip: Creases erhöhen die Komplexität und den Speicherbedarf Eures Mo-
dells. Macht sie also nur dort wo ihr sie auch wirklich braucht!

5. Texturierung des Objekts (OPTIONAL)
Es gibt zwei Möglichkeiten Texturen für Euer Objekt zu erstellen:
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(a) Malen der Textur direkt auf das 3D Objekt in Maya:
Hierzu selektiert ihr einfach Euere Subdivision-Fläche und wählt (mit
aktivem Rendering Menu-Set) den Befehl

Texturing→3D Paint Tool

Wenn ihr nun mit der Maus über das Objekt fahrt, erscheint ein
kreiskörmiger Cursor, der sich über die Oberfläche des Objekt be-
wegt. Dieser Cursor ist momentan noch durchgestrichen, was daran
liegt, dass ihr noch keine Textur zugewiesen habt. Sucht also in der
Option-Box des 3D-Paint-Tools den Eintrag File Textures, wählt das
Attribut das ihr malen wollt (idR. Color) und klickt auf Assign Tex-
tures. Es erscheint eine Dialog-Box in der ihr die Größe der Textur
in Pixeln angeben könnt.
Anschließend könnt ihr in der Option-Box des 3D-Paint-Tools die
Größe des Pinsels auswählen und die Farbe mit der ihr malen wollt
und loslegen. (Wenn sich beim Malen seltsame Effekte ergeben, z.B.
das Maya dorthin malt, wo ihr garnicht hingeklickt habt, dann liegt es
daran, dass Eure Texturkoordinaten nicht stimmen! Hört also sofort
auf mit dem Malen und behebt die Probleme im UV-Texture-Editor!)

Tip: Man kann sehr schnell die Größe des Pinsels verändern, indem
man die Taste b gedrückt hält und mit der linken Maustaste den
Pinsel auf die gewünschte Größe zieht!

(b) Verwendung externer Bildbearbeitungsprogramme Wenn ihr
mit dem Paint-Tool von Maya nicht genau genug arbeiten könnt,
ist es am einfachsten sich die Textur-Bitmap zu exportieren und
sie in einem externen Bildbearbeitungsprogramm (z.B. Adobe Pho-
toshop) zu editieren. Ihr könnt Eure 3D-Paint-Textur exportieren
(Tool-Option-Box unter File Textures→Save Texture). Das Ergebnis
liegt dann im Unterverzeichnis 3dPaintTextures in Eurem Projekt-
verzeichnis.
Oft ist es auch sinnvoll sich die Texturkoordinaten als Bild zu expor-
tieren. Im UV-Texture-Editor könnt ihr mit dem Eintrag

Polygon→UV Snapshot...

die Texturkoordinaten als Bild exportieren.
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