
1. Grundlegende Polygon-Modellierung

1.1  Polygonnetze

Ziel der Modellierungsphase ist es, reale Objekte im Rechner möglichst exakt nachzubilden. 
In der Computergraphik wird dazu die Oberfläche des Objektes meistens durch ein Polygon-
netz angenähert. Die Oberfläche wird also durch Eckpunkte definiert, die wiederum zu min-
destens einem Polygon gehören. Das gebräuchlichste Polygon  in der Modellierung ist das 
Viereck. Obwohl drei Punkte eine Ebene eindeutig beschreiben und deshalb in der Compu-
tergraphik oft Dreiecke eingesetzt werden, wird die Modellierung mit Vierecken benutzt um 
später eine bessere Animation zu gewährleisten.

1.2  Eigenschaften eines Polygons 

Ein Polygon besteht aus seinen Eckpunkten (Vertices), dazwischenliegenden Kanten (Ed-
ges),  sowie  der  darin  eingeschlossenen  Fläche  (Faces).  Polygone  sind  unendlich  dünn. 
Schaut man von der Seite auf ein Polygon, ist es nicht zu sehen.

Jedes Polygon hat eine Normale. Das ist ein Vektor, der senkrecht auf der Fläche des Polyg-
ons steht und zur Beleuchtungsberechnung dient. Die Normale bestimmt die Vorderseite des 
Polygons. Beim späteren Rendern sind nur die Polygone sichtbar, deren Normale in Rich-
tung Kamera zeigt. In Maya werden allerdings standardmässig beide Seiten beleuchtet. 

1.3  Erstellen von komplexen Geometrien 

Es existieren viele Methoden um Geometrie aus Polygonen zu erzeugen, hier die drei gän-
gigsten:

1. Jedes Polygon der Geometrie einzeln definieren (Poly-by-Poly Modelling). Es wird mit ei-
nem einzelnen Polygon angefangen, dann nach und nach weitere hinzufügen.

2. Aus Geometrischen Grundkörpern (Würfel, Kugel, Zylinder…) durch Manipulation der Verti-
ces, Edges und Faces neue Formen erzeugen (Box Modelling).

3. Das Objekt wird durch Kurven bestmöglich angenähert, woraus dann die Polygone errech-
net werden können (Spline Modellierung). 

1.4  „Gute“ Geometrie

Bei der Erstellung von Geometrie gibt es ein paar allgemeine Standards an die man sich hal-
ten sollte, um sich die Arbeit zu erleichtern:

- Ein Vertex sollte nur in Verbindung mit einer Edge existieren, Edges sollten nur in Verbin-
dung mit einem Polygon existieren.

- Verwende nur Polygone mit drei oder vier Vertices. Allgemein gilt: Verwende nur Viere-
cke, Polygone mit mehr oder weniger Eckpunkten sollten selten bis nie benutzt werden.

- Vermeide Vertices, die zwischen mehr als 4 Kanten liegen. (Das wird sich ab und zu 
nicht verhindern lassen, sollte aber die Ausnahme sein.)

- Die Polygone sollten eine Quadratische Form haben, keine zu langen, zu dünnen oder 
rautenförmigen Polygone.

- Versuche die Anzahl der Polygone so gering wie möglich zu halten. Das sorgt für flüs-
siges Arbeiten mit dem Modellierungsprogramm und erleichtert spätere Änderungen an 
der Geometrie.

- Vermeide nicht-planare Faces. Das sind Faces mit 4 Vertices, die nicht in derselben Ebe-
ne liegen. Ein Polygon sollte also keine Knicke haben.

- Innerhalb des Oberflächenmodells dürfen sich keine Faces befinden und alle Normalen 
müssen nach außen zeigen

- Vertices, Edges und Faces dürfen an einer Position nie doppelt vorhanden sein



Übung zur Modellierung mit Maya

Aufgabe 1: Objekte verändern

1. Create -> Polygon Primitives -> Sphere (= Kugel)
2. Schiebe die Kugel mit dem Translate Tool (Taste w) an die Position (x=3.0,y=0.0,z=0.0)
3. Create -> Polygon Primitives -> Cube (= Würfel)
4. Schiebe den Cube ungefähr an die Stelle (x= -3.0, y=0.0, z=0.0)
5. Create -> Polygon Primitives -> Pyramid, Pyramide bleibt an (0.0,0.0,0.0)

Erstelle aus der Szene links die Szene im rechten Bild mit Hilfe des Skalierungs- und des Rotati-
onstools (Tipp: der Würfel muss im Face Modus statt im Object Modus verändert werden).

Aufgabe 2: Löschen und Einfügen von Faces
Lösche im linken Cube das obere und das sichtbare seitliche Face:

Neu: Edit Mesh → Append to Polygon. Nach Auswahl des Tools werden Randkanten dicker ge-
zeichnet. Mit dem Tool können nun Verbindungsflächen zwischen diesen Kanten eingefügt wer-
den.Abschließen der Aktion mit Enter, danach ist die Fläche eingesetzt.

Aufgabe 3: Extrudieren

Neu: Edit Mesh → Extrude. Erstelle, ausgehend von einem Würfel mit Kantenlänge 2, die abge-
bildeten Tetris-Elemente mit Hilfe des Extrude-Tools, dem Wechsel zwischen Translation und 
Skalierung (innerhalb des Extrude-Tools) und (für das rechte Bild) der Abwahl der Option „Keep 
Faces Together“



2. Polygonmodellierung in Maya

Die bereits beschriebenen Grundlagen zur Modellierung von Polygonen gelten für jede Mo-
dellierungssoftware.  In Maya gibt  es neben den Polygonen noch zwei  weitere Arten von 
Geometrie: Subdivison Surfaces und NURBS. Wir befassen uns im Praktikum ausschließlich 
mit der Polygonmodellierung.

2.1  Geometrie erzeugen

Unter Create  → Polygon Primitives steht eine Auswahl an Grundkörpern zur Verfügung, die der 
Szene hinzugefügt werden können. 

Einzelne Polygone können in Maya mit Mesh → Create Polygon Tool erzeugt werden. Mit LMB die 
Positionen der einzelnen Vertices bestimmen und mit Enter bestätigen.  Dieses Tool sollte 
nur in  den Seitenansichten verwendet  werden,  weil  man in  der  perspektivischen Ansicht 
nicht erkennt in welcher Tiefe  die Vertices erstellt werden.

2.2  Komponenten manipulieren

In Maya kann mit RMB auf einem Objekt auf dessen Komponenten 
zugegriffen werden.  Drücke und halte RMB,  fahre dann mit  der 
Maus auf eine Auswahl, um die Komponenten zu bearbeiten. Sie 
lassen sich wie Objekte verschieben, rotieren oder skalieren.

2.3  Maya’s Modelling Tools

Maya bietet viele Tools um die Geometrie zu modifizieren. Die folgenden Werkzeuge lassen 
sich alle unter dem Edit Mesh Menü finden (z.b. Edit Mesh → Extrude). Durch die Optionbox ☐ las-
sen sich für jedes Werkzeug noch zusätzliche Einstellungen festlegen.

Extrude:

Das wichtigste Werkzeug beim Box Modelling.  Beim Extrudieren 
wird ein zweidimensionales Face „gestreckt“ um so ein 3D Objekt 
zu erstellen. Es entstehen neue Faces zwischen dem extrudierten 
Face und dem ursprünglichen. (Es ist ebenfalls möglich eine Edge 
zu extrudieren. Hierbei entsteht ein Face.)

Selektiert man mehrere, nebeneinanderliegende Faces und extru-
diert diese, so werden die Faces als ein zusammenliegendes Face 
behandelt. Möchtest du jede Face für sich extrudieren, musst du 
das Häkchen bei Mesh → Keep Faces Together entfernen.

Insert Edge Loop Tool:

Erzeugt einen neuen Kantenring in der Geometrie. Mit LMB auf eine 
beliebige  Kante  klicken  und  Maustaste  gedrückt  halten,  es  er-
scheint dann eine Vorschau in Form einer gestrichelten Linie. Die 
Kante wird erzeugt, sobald LMB wieder losgelassen wird.

Bridge:

Erzeugt automatisch neue Faces zwischen zwei Randkanten einer 
Geometrie. Dazu auf die erste Randkante doppelklicken, die zweite 
Randkante mit   SHIFT +  DOPPELKLICK  selektieren und dann das Tool 
auswählen. Mit Optionbox  ☐, kann die Anzahl der Unterteilungen 
eingestellt werden. Achtung: die Anzahl der Kanten muss bei bei-
den Rändern gleich sein!

Ein Face vor und nach dem Extrudieren. Mit den Pfei-
len kann das neue Face verschoben werden, Mit den 
Würfeln wird das neue Face skaliert



Append To Polygon:

Hiermit  können  manuell  neue  Faces  zwischen  Randkanten  der 
Geometrie eingefügt werden. Dazu klickst du mit der LMB auf eine 
der Randkanten. Es werden dann Pfeile auf den entsprechenden 
nächsten Kanten angezeigt.  Durch klicken auf  diese Pfeile  wird 
ein neues Face erzeugt. Bestätigen mit Enter.

Add Divisons:

Unterteilt  ein  Face  in  mehrere  neue  Faces.  Mit  Optionbox  ☐ 
kannst du die Anzahl an Unterteilungen festlegen.

Interactive Split Tool:

Unterteilt  ein  Face benutzerdefiniert.  Wenn die  Maus über  das 
Objekt bewegt wird, werden mögliche Vertexpositionen eingeblen-
det.  Mit  LMB auf  eine  Kante  oder  ein  Vertex  klicken  und  den 
nächsten Punkt anklicken.  Der Vorgang wird solange wiederholt 
bis mit Enter bestätigt wurde. Die Faces werden dann  durch die 
gewählten Punkte unterteilt.

Merge Vertex Tool:

Verschmelzt zwei Vertices. Mit dem Tool auf das erste der beiden 
Vertices klicken und LMB gedrückt halten. Dann die Maus auf das 
zweite Vertex ziehen. Dadurch wird das erste Vertex auf das zwei-
te geschoben und verschmolzen. 

Häufige Fehler:

Beim Extrudieren werden neue Faces in die Geometrie eingefügt. Diese haben am Anfang 
den Abstand 0 zum ursprünglichen Face, d.h. sie liegen an derselben Position. Man sieht die 
neuen Faces erst, wenn sie verschoben/skaliert werden. Ein häufiger Fehler ist es, ein Face 
zu extrudieren und dann nicht zu verschieben/skalieren. Damit hast du dann mehrere Faces 
an derselben Position, was Späteres bearbeiten extrem erschwert oder unmöglich macht.

Werden durch die Optionbox ☐ Einstellungen verändert, so merkt sich Maya diese Einstel-
lungen (z.b. die Divisions beim Extrudieren). Oft passiert es, dass man vergisst, dass die 
Standardeinstellungen überschrieben wurden und wundert sich, wenn das Werkzeug nicht 
das richtige Verhalten zeigt.



3. Einen Schrank modellieren

1. Erstelle einen Würfel mit den Größen x = 5, y = 12, z = 5. Wechsel in den Face Modus 
und markiere das vorderste Face des Würfels.

2. Extrudiere das Face, achte darauf, dass die Anzahl der Divisions auf 1 steht. Skaliere 
das neue Face etwas herunter.

3. Extrudiere das Face erneut und wechsel in die Top-Ansicht. Verschiebe das Face nach 
innen, bis es kurz vor der Schrankrückwand liegt.

Die Grundstruktur des Schranks ist fertig. Jetzt werden die Schrankeinlagen modelliert.

4. Wechsel  in  die  Front-Ansicht  und  füge  mit  dem  Insert  Edge  Loop  Tool in  der  Mitte  des 
Schranks einen Loop ein. Ein zweiter Edge Loop wird knapp darüber platziert, damit ein 
Spalt entsteht, der ungefähr die Breite einer Schrankeinlage hat.

5. Wechsel in die Perspektivische Ansicht und in den Face Modus. Markiere die drei Faces 
im Inneren des Schranks, die durch die Edge Loops entstanden sind. Lösche die Faces 
mit ENTF .

6. Wechsel in den Edge Modus und markiere die hinteren beiden Edges im Inneren des 
Schranks, dessen Faces du gerade gelöscht hast. Extrudiere die Edges bis kurz vor die 
Schrankvorderseite.

7. Wähle  das  Merge  Vertex  Tool aus  und  verbinde  die  extrudierten  Vertices  mit  den  dazu 
passenden Vertices an der Schrankvorderseite.

8. Schließe die letzte Lücke mit dem Append to Polygon Tool. 

Der Schrank hat jetzt  eine Schrankeinlage.  Du kannst durch die gleiche Vorgehensweise 
noch weitere hinzufügen. Danach wird die Tür modelliert.

9. Erstelle einen neuen Würfel mit den Werten x = 0.2, y = 11.5, z = 4.5. 
Verschiebe den Würfel so, dass er genau vor der Schranköffnung liegt. 

10. Wechsel in die Seitenansicht. Erstelle die Grundform des Griffes mit dem 
Create  Polygon  Tool.  Der  Griff  sollte  ähnlich  der  Abbildung  aussehen. 
Orientiere dich dabei bestmöglich am Raster. Wenn du mit der erstellten 
Grundform nicht ganz zufrieden bist,  kannst du die einzelnen Vertices 
auch nachträglich noch ändern.

11. Wechsel wieder in die Perspektivische Ansicht und in den Face Mode. 
Markiere das eben erstellte Face und extrudiere es. Verschiebe es, bis 
es die gewünschte Griffbreite hat.

12. Der Griff ist noch etwas kantig. Drücke 3 um den Griff abzurunden.

Wer jetzt eine schöne runde Geometrie erwartet hat, wird enttäuscht, das Objekt sieht nicht 
mehr wie ein Griff aus. Schuld daran ist das Polygon, das in Schritt 7 erstellt wurde. Es hat 
mehr  als  4 Edges und ist  somit  ungültig.  Beim Abrunden entstehen dann Fehler.  Diese 
Fehler können jedoch behoben werden, indem das ungültige  Polygon in kleinere Polygone, 
mit nur 4 Edges aufgeteilt wird. 

13. Wechsel wieder zur kantigen Version zurück indem du 1 drückst. Dann 
benutze das Interactive Split Tool um das ungültige Polygon zu unterteilen. 
Unterteile dabei immer zwischen zwei Vertices, so dass ausschließlich 
viereckige Polygone entstehen. Mit G kannst  du das zuletzt benutzte 
Werkzeug wieder aufrufen.

14. Unterteile auch die andere Seite des Griffes und drücke erneut 3. Der 
Griff sollte nun rund sein.

15. Lösche die Faces am oberen und unteren Ende des Griffes. Positioniere 
den Griff in mittlerer Höhe an der Tür. Vorher solltest du den Pivot Point 
zentrieren, was das verschieben erleichtert. Dazu: Modify → Center Pivot.


